0
\$\begingroup\$

I built a 2D game using Unity3d 5.1.1. When i build and run the project with iPhone connected, the game runs fine on the device. But when i select simulator instead of device, i get an error : " does not have an architecture that can execute" . I run the game on iPhone 4S, but cannot run on the iPhone 4S simulator. Similarly, i selected iPhone 6, 5 etc and get this error every time.

\$\endgroup\$
0
\$\begingroup\$

In Player settings → Optimizations → SDK, I had to select simulator SDK, instead of device SDK. That resolves this.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.