2 added 1350 characters in body
source | link

To solve your question, we need to start with some base understanding; planes are flat, by definition:

plane

  1. a flat surface on which a straight line joining any two points on it would wholly lie.

    "the horizontal plane"

    synonyms: flat surface, level surface;

- "Plane" as defined by a quick Google search"Plane" as defined by a quick Google search (emphasis mine)

In fact, they only appear under "3D" in Unity because they are rendered in 3D space, using 3D drawing concepts. As a result, they look like flat lines, when viewed at from the side. Exactly as shown in your first screenshot.


In your screenshot, it appears your moving directly along the Z axis. It is most likely that you have initialised your Unity project in 2D, as opposed to 3D. Contrary to the answer provided by lilotop, there is no real reason to restart in 3D. Unity does not need to handle 2D and 3D across separate projects. There should only be two settings that need to be changed, for a new project.

To change between 2D and 3D mode, select or deselect **2D** from the top left corner of the Scene view.To change between 2D and 3D mode, select or deselect **2D** from the top left corner of the Scene view.

When you start a 2D project, you will start in 2D mode, in the Scene view. This means that you will start off looking directly along the Z axis. It also means that ALT + RMB will pan the view. If we swap to 3D mode, in the Scene view, ALT + RMB will rotate the view, and let us see the plane in full 3D.

enter image description hereIn 3D mode, we can see the shape of the plane, rotate around our scene with the mouse and observe all 3 axis in the top right corner of the Scene view.

If you truly did start your project in 2D mode, there is one last thing we need to do. The camera used to render your game to the screen will likely be set to Orthographic, to render the area as a 2D image. It needs to be set to Perspective, to render an area in 3D. You will likely have to play around with it to get the exact perspective you want; but playing around with it is the only real way to learn - and you will likely have to do so regardless of it's initial settings.

The *Projection* setting of your Camera should be set to *Perspective* to render 3D images.

To solve your question, we need to start with some base understanding; planes are flat, by definition:

plane

  1. a flat surface on which a straight line joining any two points on it would wholly lie.

    "the horizontal plane"

    synonyms: flat surface, level surface;

- "Plane" as defined by a quick Google search (emphasis mine)


In your screenshot, it appears your moving directly along the Z axis. It is most likely that you have initialised your Unity project in 2D, as opposed to 3D. Contrary to the answer provided by lilotop, there is no real reason to restart in 3D. Unity does not need to handle 2D and 3D across separate projects. There should only be two settings that need to be changed, for a new project.

To change between 2D and 3D mode, select or deselect **2D** from the top left corner of the Scene view.

When you start a 2D project, you will start in 2D mode, in the Scene view. This means that you will start off looking directly along the Z axis. It also means that ALT + RMB will pan the view. If we swap to 3D mode, in the Scene view, ALT + RMB will rotate the view, and let us see the plane in full 3D.

enter image description here

To solve your question, we need to start with some base understanding; planes are flat, by definition:

plane

  1. a flat surface on which a straight line joining any two points on it would wholly lie.

    "the horizontal plane"

    synonyms: flat surface, level surface;

- "Plane" as defined by a quick Google search (emphasis mine)

In fact, they only appear under "3D" in Unity because they are rendered in 3D space, using 3D drawing concepts. As a result, they look like flat lines, when viewed at from the side. Exactly as shown in your first screenshot.


In your screenshot, it appears your moving directly along the Z axis. It is most likely that you have initialised your Unity project in 2D, as opposed to 3D. Contrary to the answer provided by lilotop, there is no real reason to restart in 3D. Unity does not need to handle 2D and 3D across separate projects. There should only be two settings that need to be changed, for a new project.

To change between 2D and 3D mode, select or deselect **2D** from the top left corner of the Scene view.

When you start a 2D project, you will start in 2D mode, in the Scene view. This means that you will start off looking directly along the Z axis. It also means that ALT + RMB will pan the view. If we swap to 3D mode, in the Scene view, ALT + RMB will rotate the view, and let us see the plane in full 3D.

In 3D mode, we can see the shape of the plane, rotate around our scene with the mouse and observe all 3 axis in the top right corner of the Scene view.

If you truly did start your project in 2D mode, there is one last thing we need to do. The camera used to render your game to the screen will likely be set to Orthographic, to render the area as a 2D image. It needs to be set to Perspective, to render an area in 3D. You will likely have to play around with it to get the exact perspective you want; but playing around with it is the only real way to learn - and you will likely have to do so regardless of it's initial settings.

The *Projection* setting of your Camera should be set to *Perspective* to render 3D images.

1
source | link

To solve your question, we need to start with some base understanding; planes are flat, by definition:

plane

  1. a flat surface on which a straight line joining any two points on it would wholly lie.

    "the horizontal plane"

    synonyms: flat surface, level surface;

- "Plane" as defined by a quick Google search (emphasis mine)


In your screenshot, it appears your moving directly along the Z axis. It is most likely that you have initialised your Unity project in 2D, as opposed to 3D. Contrary to the answer provided by lilotop, there is no real reason to restart in 3D. Unity does not need to handle 2D and 3D across separate projects. There should only be two settings that need to be changed, for a new project.

To change between 2D and 3D mode, select or deselect **2D** from the top left corner of the Scene view.

When you start a 2D project, you will start in 2D mode, in the Scene view. This means that you will start off looking directly along the Z axis. It also means that ALT + RMB will pan the view. If we swap to 3D mode, in the Scene view, ALT + RMB will rotate the view, and let us see the plane in full 3D.

enter image description here