1
vote
0answers
64 views

Assimp skeletal animation matrices

I startded to make an assimp only opengl skeletal animation demo. For that I used this: http://sourceforge.net/p/assimp/discussion/817654/thread/5462cbf5 And something is not correct in bone matrices. ...
0
votes
0answers
124 views

Why does Assimp appear to be loading vertices in the incorrect order in this code?

I'm getting a weird bug in my code that is reading in the vertices from an .obj file. The .obj file is just a cube, hence there are eight vertices. When I print out the vector it seems to work ...
-1
votes
1answer
104 views

Opengl Obj with multiple textures. Jpg texture don't display

Hi i have problem with jpg textures. DDS is working good but jpg is not. This is my function to load JPG texture. In debuger i see that this works but i dont see anything. char * a =(char *) ...
0
votes
0answers
148 views

bones programmatically in assimp

I am trying to animate a 3d hand object programmatically in Assimp, I have the 3d model being export to collada using Blender. But I have no idea how to go from one bone animate it and then go to the ...
2
votes
1answer
252 views

Multiple texture coordinates per mesh?

So far I've used the same texture coordinate for both the normal and diffuse textures on a mesh, yet when reading the Assimp documentation ...
13
votes
1answer
928 views

Normals vs Normal maps

I am using Assimp asset importer (http://assimp.sourceforge.net/lib_html/index.html) to parse 3d models. So far, I've simply pulled out the normal vectors which are defined for each vertex in my ...
2
votes
2answers
649 views

ASSIMP in my program is much slower to import than ASSIMP view program

The problem is really simple: if I try to load with the function aiImportFileExWithProperties a big model in my software (around 200.000 vertices), it takes more than one minute. If I try to load the ...
0
votes
1answer
550 views

Direct3D11 + Assimp imported model corrupted/failed

I use Assimp library to import vertex and index data from model file. I don't know how to correctly create index buffer from mFaces array of aiMesh. Or something wrong, because i my model is ...
2
votes
1answer
834 views

smooth shading vs flat shading, what's the difference in the models?

I'm loading the exact same model with Assimp, except one is exported from Blender, shaded smoothly, and the other was exported from Blender, shaded flatly. Here is my results from loading both into my ...
1
vote
2answers
3k views

Using Assimp to load dae files

I've started looking into using Assimp to load in dae collada files into my game. I believe I've managed to load the file into aiscene. I am using c++, OpenGL and SFML. My problem lies with ...
1
vote
1answer
122 views

How to remove a node from a scene imported with Assimp?

I need to remove one object from the scene graph imported by Assimp and I can't. I've tried to change aiScene.h including a method called DelNode and I canĀ“t. How can I do it - is it possible?
4
votes
1answer
813 views

Strange mesh import problem with Assimp and OpenGL

Using the assimp library for importing 3D data into an OpenGL application. I get some strange problems regarding indexing of the vertices: If I use the following code for importing vertex indices: ...
1
vote
1answer
700 views

Child transforms problem when loading 3DS models using assimp

I'm trying to load a textured 3d model into my scene using assimp model loader. The problem is that child meshes are not situated correctly (they don't have the correct transformations). In brief: ...
15
votes
2answers
9k views

I can't figure out how to animate my loaded model with Assimp

I have loaded in a model to my C++ OpenGL game. It is a COLLADA file type that I have loaded, and I setup an animation under blender for the file. The problem is I don't know how to animate the model. ...
5
votes
1answer
1k views

Problem with Assimp 3D model loader

In my game I have model loading functions for Assimp model loading library. I can load the model and render it, but the model displays incorrectly. The models load in as if they were using a seperate ...