Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I am new to unity. I have created an asset by using Blender and managed to put it in the scene. But somehow now I can only see one item at a scene. For example I can only see camera when I clicked "Main camera" at the Hierarchy toolbar. When I clicked the asset, the camera is hidden from the scene along with lighting etc. This is difficult for me since I need to put my asset in front of the camera. Where can I toggle back the views for everything in the scene?

share|improve this question

3 Answers 3

You should have the "Gizmos" menu in the scene view, check if everything is checked there, you should also know that importing from blender will naturally downscale your objects to 0.1 of their scale, you can change that by setting scale back to 1 in the import settings.

When your objects are downscaled to the point you cannot see them if you focus on one of them you'll loose the visibility over the gizmos and vice versa.

If after checking this it is still occuring could you post the specifics of your scene setup?

share|improve this answer
    
As far as I remember everything is checked in the Gizmos. I have created new scene though, so I cannot check what went wrong. I will update again if I run into it in the future. –  Songbreaker Feb 17 at 8:52

Do you mean you don't have a scene view? A screenshot would help determine what is the issue. But if you don't have a scene view you can right click any of the tabs e.g "Hierarchy" and select Add Tab-> Scene.

share|improve this answer
    
I have a scene view, but I cannot see all items in the view. I can only see an item when I clicked at the hieararchy. So I cannot see the overall picture. This really screwing up my camera view. –  Songbreaker Feb 17 at 7:51

I think your camera is not focusing your asset. Make your camera look at your asset. Set camera's position to 0,0,0 and your asset's position to 0,0,10. You can find your asset now. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.