Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I created a new Windows Phone Game (4.0) project in Visual Studio Express 2012 and added the Farseer project to the solution explorer. But adding a reference to the Farseer project is not working. I always get this error message:

A reference to 'Farseer Physics XNA WP7' could not be added. References with different refresh levels are not supported.

What is wrong? How can I use Farseer in Windows Phone 7/8?

I uploaded the two projects on pastebin.

Farseer project: pastebin.com/uyRusHxM

Windows Phone project: pastebin.com/s74Gr66y

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

If your project is 7.1 and Farseer is 7.0

Right click the Farseer project and click Upgrade to Windows Phone 7.0.

If your project is 8.0 and Farseer is 7.1 or below

To upgrade to WP8.0 is more of a pita though not too bad.

You will need to edit the csproj file for both projects. So for both of them.

  1. Right click the project in the solution explorer and select “Unload Project”.
  2. Right click the project again and select “Edit csproj”.

This option is out of synch between the two projects. Find out the status of the XnaRefreshLevel tag in your project. I think it should be <XnaRefreshLevel>1</XnaRefreshLevel>. If so add that option under the same grouping in the farseer project. It may not be but the point is to make it so that the Farseer project has the same XnaRefreshLevel entry as your project.

share|improve this answer
    
I did the right click on the Farseer project but their is no 'Upgrade to Windows Phone 8.0'. What can I do? –  Bryan Jun 19 '13 at 19:38
    
Forgot that there was 8.0 now a days. Hopefully my edit helps. –  ClassicThunder Jun 19 '13 at 20:13
    
I did the right click on the Farseer project but their is no 'edit solution file'. How can I edit the solution file? –  Bryan Jun 19 '13 at 20:24
    
Did you unload it first? –  ClassicThunder Jun 19 '13 at 20:25
    
OK. I'm trying it. –  Bryan Jun 19 '13 at 20:37
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.