Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I'm creating an alien in blender, doing my best to base it on the guys from toy story. When I create the UV Map and colour it, import it back in then take a look at it in a seperate window there is alot of black segments on it. Ive tried the whole SMART UV PROJECT option aswell but I still get the same thing. What have I done wrong here?

enter image description here

Update: Followed advice below and can now colour without the black segments seen in the first pic, however I am now seeing lines on my alien, is this because of GIMP? (Im using GIMP to colour my guy)

enter image description here

share|improve this question
    
From your screenshot it looks like you have some quads that aren't being included in the UV projection (because they are still taking up the whole UV square). Also, if this is a subdivision model, try casting to a mesh first and then see how it looks. –  indeed005 Feb 25 '13 at 21:55
add comment

1 Answer 1

First off, make sure you're adding a material on your mesh, then add the texture, set it as "image or movie", and chose "Coordinates: UV":

enter image description here

share|improve this answer
    
Thanks for the reply, yea I have been doing that, im still getting the above result. –  Craig Feb 25 '13 at 21:41
    
Do you get the same result if you simply load the image on the UV unwrap and set your viewport mode to textured? Finally, if noone has a better suggestion, make available a link with your blender project and texture and I'll try looking into it. –  Shivan Dragon Feb 25 '13 at 21:43
    
Sorry Im a blender noob! How would i go about doing that? –  Craig Feb 25 '13 at 22:04
    
Make 2 viewports: drag upper-right corner of current viewport to left -> Click on lower-left Cube icon, set one of the viewports to UV/Image Editor. Still here, from lower menu select image->new->ok. Select your mesh in the other viewport. TAB to go to edit mode. Select all faces (A). If you've properly UV-unrapped them you should see that unwrapping in the viewport you set to UV/Image editor. Select that viewport (the one with the UVs), and from the lower menu, select Image->open Image and select your texture. In the viewport with the mesh, select View Port Shading:texture from lower menu. –  Shivan Dragon Feb 25 '13 at 22:21
    
Thanks so much, works perfectly!! :) One last question, when I do that the colours work perfect, but I now have permanent lines on my alien, how do i remove those? –  Craig Feb 25 '13 at 22:36
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.