Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using Monodevelop's current version and Unity 4. I don't get intellisense on the classes I've created but I do have intellisense on classes that are in Unity's framework. Bug or its just as it is?

I use UnityScript:

class SomeClass extends ScriptableObject{
    public function Test(){return "";}

In another class, when I use a variable typed as this class I get no intellisense.

share|improve this question
You tried rebuilding, re-opening your project/soln right? – XiaoChuan Yu Jan 11 '13 at 4:56
yes, i tried to rebuild, re-open the project, resync in unity – Dr.Denis McCracleJizz Jan 12 '13 at 18:55
up vote 1 down vote accepted

There just isnt any intellisence on custom classes when using UnityScript unless they are in the same file. Which is very unconvinant.

I Switch to C# with Monodevelop.

Thanks anyways.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.