Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i just made a 3d game in XNA for windows phone 7. I build it in release mode on visual studio 2010 and suddenly when I run game there is no textures on models - 2 models are black and one is transparent. Models are in .X format exported from 3dsmax and have textures in .jpg also added to game content. I set build action to none and all worked fine in debug mode. When I change to release mode - black textures. When I set build action to compile it gives me warning:

Asset was built 2 times with different settings: using TextureImporter and TextureProcessor using TextureImporter and TextureProcessor, referenced by...

and still no textures.

What can I do?

share|improve this question

closed as off-topic by Josh Petrie Dec 17 '14 at 17:44

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about debugging a problem in your project must present a concise selection of code and context so as to allow a reader to diagnose the issue without needing to read all of your code or to engage in extensive back-and-forth dialog. For more information, see this meta thread." – Josh Petrie
If this question can be reworded to fit the rules in the help center, please edit the question.

Try not adding the textures to the content project. Most model formats describe the texture locations relative to the models location and the processor is smart enough to go fetch them, so there is no need to specify them. I'm am not sure how this would break anything but its a start for identifying the issue. Its possible that possessing the image alters it in such a way that the model importer is not expecting such as pre-multiplying the alpha to the color channels or something similar. – ClassicThunder Jan 10 '13 at 16:56
If you need the textures for use other than rendering the models duplicate them and add the duplicated files. – ClassicThunder Jan 10 '13 at 16:57

Try to delete the photo texture of the visual studio and try again it happened to me im using a .fbx format and work fine the first time ill try it it give me and error when it read the texture so I delete it and it work fine also make sure you export option in 3dmax. hope it work for you xD.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.