Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

It is now available for download. It says you need twice* as many bits as I have. Why would you need more bits to compile code? Does that mean you need more bits to run flash games writtes with flasCC

Did anyone try it out and happens to know the answers?

http://gaming.adobe.com/technologies/flascc/

Minimum system requirements
    Flash Player 11 or higher
    Flex SDK 4.6 or higher
    Java Virtual Machine (64-bit)
Windows
    Microsoft® Windows® 7 (64-bit edition)
    Cygwin (included)

*This is meant as a joke. however I do own a 32-bit laptop and I am wondering why you need 64-bit. Afaik - You only need 64-bit if you want to run a system that has more than 4gigs of memory. Why would any flash game require more than 4 gigs of memory.

The only system that is 64-bits and does not have 4gigs of memory that I can quickly recall is that hilarious Nintendo that came ages ago with a Motorola CPU.

share|improve this question

3 Answers 3

http://www.adobe.com/devnet/games/articles/flascc-tips-tricks.html

Adjust Java memory allocation

Although it is strongly recommended that you use 64-bit Java with flascc, some developers have been able to use 32-bit Java for certain, small applications. In this case, if the machine has limited memory, you may need to reduce the Java heap specification (the default is –jvmopt="-Xmx1500m") to a smaller number, for example, –jvmopt="-Xmx256m". You can do this when invoking GCC in the makefile. For example:

So there is a way. It is good to know people are able to run the demo. It would look lame if your app was 64-bit only in 2012 although it will be find in 2016 imho.

share|improve this answer

My guess is that they are forward-looking and see that a 64-bit build will be needed eventually (esp. related to stuff like unreal engine), and don't want the hassle of supporting both 32bit and 64bit versions.

share|improve this answer

64bit does not only mean access to more memory, it also means larger word size. So larger instructions. I'm not sure why FlasCC requires it, but it clearly does (as shown in the minumum system requirements).

I was able to run the demo on both x86 (32 bit) and x64 (64 bit) systems. So it appears the 64 bit is only required for the compiler.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.