Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

Any ideas on how to fix this? According to what I remember about XNA 3 was that when running the application from scratch, I would get a blue colored windows with nothing rendered.

Any suggestions?

alt text

EDIT!

I right clicked the project and selected Properties and changed the Game Profile from Use HiDef to Use Reach. Now the familiar blue tint window is showing as expected. alt text

What am I losing if I choose the limited API and why did I even have to choose this for it to work?

share|improve this question
2  
As a sidenote, I wonder why they chose to call it "Reach"... I just got done playing some Halo: Reach so that came to mind immediately. But I suspect it's more because of the symbolism of "reaching" more devices? –  Ricket Oct 4 '10 at 4:47
    
Sorrry,but i dont know where are these project properies. Could someone tell me? –  user7354 May 14 '11 at 7:36
    
@Romantyk12 - i56.tinypic.com/2iqeu6t.png Hopefully this image helps. After clicking properties on the right-click pop up, the first tab labelled 'XNA Game Studio' has settings near the top to choose Reach or HiDef profile. –  DMan May 14 '11 at 15:48

2 Answers 2

up vote 8 down vote accepted

To answer your follow up question:

What am I losing if I choose the limited API?

This blog post explains the differences between Reach and HiDef. In a nutshell, the Reach profile does not allow the use of some of the more advanced graphics card features. But it runs on more hardware.

share|improve this answer
    
after changing properties to reach same error is appearing –  user26573 Feb 20 '13 at 21:45
    
@maryam It's possible that your graphics card does not support the requirements of even the Reach profile, which requires at least Shader Model 2.0, and a few other features which should be common on GPUs of that era - see the table linked in my answer for details. (Unless the error message itself still says "HiDef profile" - then you've not changed the setting correctly / for the correct project.) –  Andrew Russell Feb 22 '13 at 11:51

XNA Framework HiDef profile requires a DX10 capable video card.

If you have a DX10 capable card, make sure your latest display drivers are installed.

If you don't have a DX10 capable card go into project properties and change the profile from HiDef to Reach.

Edit: I see you answered your own question, but to answer your question about what you will be missing:

Probably antything related to DX10. I can't remember the exact differences in my head, but lighting and particle effects are two areas where DX10 excels over DX9.

share|improve this answer
    
It needs a card that had most of the capabilities that a DX10 card has, but it still runs on DX9. –  LukeN Feb 21 '13 at 6:47
    
Between DX9c and DX10 there are increases to the max texture size, increases to the maximum # of texture references, increases on the number of shader commands to name a few. –  RobCurr Feb 22 '13 at 22:22

protected by Tetrad Feb 20 '13 at 22:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?