Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I have changed the scale to my own and now I cant create any object, including circle, if it is of the size which is normal for my scale. I am to create big object first and then modify it to smaller size. Looks like minimal size protection is set somewhere. Where?

UPDATE

While creating a circle, if I drag for 0.04m circle disappears after drag end. If I drag for 0.08m circle also disappears. If I drag for more than 0.1m, circle persists after drag end.

How to set so that it persist after 0.01m too?

share|improve this question
    
You should tell us which part of the code is giving you this problem or what you are trying to do because, without that, it is almost impossible to tell you what is wrong with it. But maybe it is because you don't quite understand the scaling. Please give us more details before you expect an answer. –  Madcowe Oct 17 '12 at 23:39

2 Answers 2

It's probably because the camera that renders your editor window has a near and far range that it uses to display the circles (spheres?) called the clipping plane. It's a good idea to get in the habit of working in a real unit system like meters, inches 3dsmax has always had the issue of working at small scales. If you select the object and retarget it with the camera, it may adjust the clipping plane to make the object visible. So if your sphere is a basketball, make it the actual size of a basketball given the units you are working in.

share|improve this answer
    
I have encountered this in 3ds max as well - it's not a case of the object not being visible. If the object is too small when you click to confirm creation, it will not be created. I don't think you can adjust this threshold anywhere, just scale up your unit system to something reasonable and you shouldn't encounter this quirk. –  melak47 Oct 18 '12 at 0:24

The problem is with your unit setup.

If you require centimeter accuracy, set your system units to centimeters (and your display units to meters if you like).

You will then have no problem creating circle shapes of centimeter (or even millimeter) radius.

Alternatively, use the keyboard creation tool instead of clicking and dragging, and you should be able to create the circle as well.

At some point you may also want or need to increase the precision of displayed values, in the preferences the default is 3 decimal places.

share|improve this answer
    
Thanks! But where to set this? I set Meters in Units Setup dialog and "1 Unit = 1,0 Centimeters" in System Unit Setup dialog, but still can't create small circles. –  Suzan Cioc Oct 19 '12 at 17:23
    
Using 1.0 cm system unit scale and 1 m display units, the smallest circle I can create by dragging is of 0.001 m radius. –  melak47 Oct 20 '12 at 0:44
    
I don't have a value in display unit setup, only "flavor", like "meters", "centimeters" and so on, without setting how many of these units. May be I am looking into different place? –  Suzan Cioc Oct 20 '12 at 22:20
    
no. you are looking at the right settings. –  melak47 Oct 21 '12 at 0:46
    
Hence the reason is different. –  Suzan Cioc Oct 21 '12 at 8:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.