Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I uploaded my layered Maya (Maya 2012) Textures via objLoader into my opengl project. I also uploaded 3D textured model. I am able to render a model but not even one texture is showing. Before pasting any code here, i thought maybe there is some common mistake that we beginners are doing, regarding this issue!?

share|improve this question

closed as not a real question by Nicol Bolas, Jonathan Hobbs, Josh Petrie, Trevor Powell, Byte56 Oct 24 '12 at 17:20

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Hello, and welcome to Game Development, please show us at least some code to make sure we can help you by doing our best for it. –  Axel Isouard Sep 26 '12 at 18:45

1 Answer 1

Displaying vertex and colors from and imported model is always a snap but showing a texture has many factors involved with it. You might not solve this problem in one day, but there is hope.

I'm going to suggest you UV map your texture properly, avoid using any layers or what not. Maybe your application doesn't support multitexture. So, UV mapping is the simplest way to do things. Then try it out to see if it works.

I'm certain your model loader supports UV mapping.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.