Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I've been using Blender for two days now, and ran into an issue while following a tutorial.

Before anything else, I'd like to show you all what my problem precisely is. Here is a short video I uploaded: click here. I thought it may be easier for you all to help me identify and solve my problem more accurately with a visual aid.

I would like to emphasize that this issue began to occur after I extruded that trapezoidal region (misstated as a parallelogram in the video). I decided that I did not want the extruded region, and just hit undo. Ever since then, I began to experience the problem you viewed.

Thanks.

share|improve this question
1  
extrude seems to work as a 2-step process: a duplicate-and-connect verts, and then a move. I think You need to hit undo twice to fully reverse the extrude. –  Jimmy Aug 29 '12 at 23:04
    
Agreed. Though, it's odd that there are vertices completely disconnected from any face. Some other weirdness going on as well, likely even more extra vertices. –  Byte56 Aug 29 '12 at 23:08
add comment

1 Answer

up vote 2 down vote accepted

You have extra vertices overlapping. You can merge them so you can get what you're expecting.

  1. Switch to edit mode like you are in your video
  2. Press B to go into box selection mode
    1. Ensure you have deselected "Limit Selection to Visible" or switch to wireframe mode
  3. Draw a box around one of the four corners your having issues with (to select all the vertices there)
  4. Press Alt+M to merge and select center
  5. Repeat for each of the 4 corners
  6. Observe that you now have 1 vertex per corner and they move like you expect.
share|improve this answer
    
Thanks, that worked! I also had to deselect the "Limit Selection to Visible" option. I had earlier ran into a related problem where I deleted the face of that trapezoid shape, and was left with only the edges and vertices (I was able to see inside the model because it left a hole). If this question is not off topic, how would you suggest I fix that? I would need to fill the shape somehow. Thanks again! –  capcom Aug 29 '12 at 23:38
    
If you're trying to fill a hole in a model, you can select the vertices surrounding the hole and create a new face. See my answer here for more details about that. Thanks for the feedback too, I usually work in wireframe mode, so I often forget about the limiting to visible option. –  Byte56 Aug 29 '12 at 23:44
    
Thanks, that's perfect. I keep alternating between modes at the moment (as I am still learning). –  capcom Aug 29 '12 at 23:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.