Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I'm having a really hard time getting the shadows the become transparent. I've looked online and followed tutorials, but it's not working(See Below).

enter image description here

It may be a little difficult to see so you should look at it in a different window.

How do I add transparency to the shadow(color less saturated), in a way to make the light look like it goes through the crystals?

share|improve this question
    
The term you should look for is caustics, when doing these type of shadows. –  ChrisC Aug 22 '12 at 21:39
    
how about a close-up of the crystal shadows? –  ashes999 Dec 21 '12 at 18:02

2 Answers 2

I'm not sure if your materials are set up correctly, but your floor mesh should have the Receive Transparent option (I'm supposing the object selected is one of the crystals)

share|improve this answer

One option is to set the "Shadow Color" of the light that's set to cast the shadows. Check under the Shadow settings for a colour box.

The only drawback is that it changes the shadows for all objects in the scene. You might be able to use light groups or layers somehow to limit the shadow's effects, but I don't know how that would work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.