Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I am modeling a tank and I don't know what key I've pressed, but now the object in Maya is looking very weird.

image of tank with some parts visible that shouldn't be and some strange artifacting

Does anybody know how to solve this problem?

share|improve this question
    
Looks some faces have inverted normals? I don't use Maya so I can't tell you how to fix that. Make regular backups... Have you tried "Undo"? –  Byte56 Apr 30 '12 at 22:43
    
Yeah stupid of me, Undo doesn't work because I saved and restarted the program, because I thought it was just a bug... –  Joris Apr 30 '12 at 22:53
    
Nothing helps, flipping normals, faces, just nothing :( god why I put so much work in this... –  Joris Apr 30 '12 at 22:57
    
Does it only look this way in shaded mode? How about wireframe? Does that look normal? –  Byte56 Apr 30 '12 at 23:10
    
Is it possible to link to a larger image? –  Inisheer Apr 30 '12 at 23:55

3 Answers 3

up vote 4 down vote accepted

The issue was due to z-fighting in an inaccurate depth buffer. The reason the depth buffer got inaccurate was because your camera's near and far clipping planes had gotten too far apart. Basically, the depth buffer has a limited number of possible depth values that are spread out between the near and far clipping planes. Thus as the clipping planes get further apart, the depth values spread apart as well.

I believe the far clipping plane in Maya gets pushed out automatically as you zoom the camera, so going to an extreme zoom will cause this issue.

The reason pasting your model in a new file fixed the issue was because the camera's near and far clipping planes were reset.

share|improve this answer

To fix this issue you want to go to

  1. view>camera attribute editor. in the panel windows, and then in the attribute editor change the
  2. near clip plane to 0.100 (or whatever works for your scene).
  3. far clip plane to 10000.000 (or whatever works for your scene).
share|improve this answer

Sorry guys, I fixed it. I just had to copy the object, open a new file and paste it in there. I still don't know what the cause of this problem was, but this is a solution.

Thanks everyone for helping, thanks a lot!

share|improve this answer
    
This likely means that your issue was what jhocking suggests. –  Byte56 May 1 '12 at 23:53
    
jhocking would probably appreciate you choosing his answer as the correct one... –  Tim Holt May 2 '12 at 2:42
    
I answered earlier then he did, so I didn't have the chance... –  Joris May 2 '12 at 11:31
    
Also you should learn to have a little patience, I'm not on gamedev all day, I have a busy life next to this. –  Joris May 2 '12 at 11:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.