Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently updated my tablet to Android 4.0.3 and now the textures for my game do not show up. I'm using OpenGL-ES 2.0 for my engine. It worked fine when I was running android 3.0. Is there any reason as to why this is happening?

share|improve this question
How are you loading the textures? What file format are you coming from? You say they aren't showing up -- do you see black instead? Have you tried manually creating a pink (etc) texture in place of your normal ones to see if that shows up? – stephelton Apr 26 '12 at 17:34
thanks for the replies, I actually fixed the problem about an hour after i posted the question, I'll consider your advice in the future. – secheung Apr 27 '12 at 4:39
Then you should explain what the problem was so others might benefit. – stephelton Apr 27 '12 at 13:49
up vote 3 down vote accepted

It's not terribly well documented, but there are some events which cause an OpenGL context loss on android. Make sure your textures are reloaded after every context loss.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.