Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a newcomer to XNA, and I'm evaluating some libraries. The Hilva Graphics Engine looks interesting, and I'm trying to run their tutorials. However, all of them give me errors.

For example, if I download the ParallaxMappingSample demo, and try to build it, I get

Error   1   Error loading pipeline assembly "C:\Users\Me\Desktop\ParallaxMappingSample\Hilva.Content.dll".  ParallaxMappingSample

I get similar errors for all of the samples. Unfortunately, this error isn't very enlightening. I can see the Hilva.Content.dll in the appropriate directory. I tried removing and readding the reference from the content project, but I get the same error.

I'm not sure it's relevant, but I'm on Windows 7, I'm using Microsoft Visual Studio 2010, and XNA 4.0.

Is there an easy (or difficult) solution?

EDIT: If you happen to try this, even if you don't have a solution, let me know about it in a comment. Whether it works for you, or if you get the same problem...either result would be something that might let me know if it's just a problem with the tutorial, or if it's on my end.

share|improve this question

closed as off-topic by Anko, Seth Battin, Josh Petrie Feb 26 '14 at 4:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about debugging a problem in your project must present a concise selection of code and context so as to allow a reader to diagnose the issue without needing to read all of your code or to engage in extensive back-and-forth dialog. For more information, see this meta thread." – Josh Petrie
If this question can be reworded to fit the rules in the help center, please edit the question.

I get the very same error with everyone one of their samples also. I did leave an email on the Hilva Site, and eventually did get reply's but so far none of the reply's I have received can tell me how to get it to compile without erroring, they claim it works for them and they don't don't why it doesn't work for me. I also and running on Windows 7, Visual Studio 2010 Ultimate, XNA 4.0 refresh. – user16019 May 6 '12 at 4:43
Same problems with me. I think this clarifies the problem a bit. So I think all their XNA tutorials are just plain broken for XNA 4.0 at least. – Petr Abdulin May 6 '12 at 21:09
This question appears to be off-topic because it is about errors in a specific set of tutorials that are known to break on new XNA versions. It would be best brought up with the tutorials' author. – Anko Feb 25 '14 at 0:30
It wasn't known to me that those tutorials would break with new XNA versions, hence the question. – Beska Feb 25 '14 at 2:45