Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

So I've a 3d game project I'm working on and I'm using 2 model files (SkyBlock.x and AimedBlock.x).

So until now everything was all good and my models files were compiled all okay and I was able to use them within my game. With the latest changes (which I don't know what caused it really) - XNA stopped compiling my model files and instead only outputs files;

  • AimedBlockxnb - 1kb
  • SkyDome.xnb - 1kb
  • SkyDomeTexture.xnb - 1389 kb
  • SkyDomeTexture_0.xnb - 419 kb

So I created a test XNA game project and moved all my asset's to new solution content project's and tried compiling them and saw that they're all good.

  • AimedBlockxnb - 2kb
  • SkyDome.xnb - 13kb
  • SkyDomeTexture.xnb - 4097 kb
  • SkyDomeTexture_0.xnb - 683 kb

So I guess my main project sucks there but I couldn't came with a solution. I even tried overwriting my game's content project with new game's content project (which was all okay) but it didn't work.

Anybody had similar issues?

share|improve this question
    
You might try rebuilding the whole solution (Ctrl+Alt+F7 or Build > Rebuild Solution) –  Mike C Apr 3 '12 at 1:20
    
I've tried it a million times - and even more manually deleted my bin/ and obj/ folders. –  HuseyinUslu Apr 3 '12 at 7:53
    
That's strange. So after manually deleting the files did not regenerate after rebuilding? –  Mike C Apr 3 '12 at 16:39

1 Answer 1

When you place content in your XNA project, in the Properties window you can pick the Build Action as well as how the file should be handled (Content Importer and Content Processor).

In your case, I expect those three properties were changed, but the defaults clearly work for you. The default for the Build Action is Compile, and the defaults for the Content Importer and Processor depend on the file format.

share|improve this answer
    
No my build action's are all properly setup. –  HuseyinUslu Apr 3 '12 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.