Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

Is it possible to export my UDK 2 project to UDK 3 ? What kinds of things aren't transferable?

share|improve this question
add comment

2 Answers 2

The answer to your question is given over here

http://udn.epicgames.com/Three/DevelopmentKitFAQ.html

Q: Can previous Unreal Engine 3 projects be imported?

A: Yes, users can open Unreal Engine 3 packages made with previous UDK releases in more recent UDK Betas with iOS support.

So if you have made some projects in UDK 2 it will work in udk 3 with some changes to the project file in the kismet and basically some code changes.

share|improve this answer
    
That is not what that says. It only talks about different versions of UDK3. UDK2 didn't have kismet but only used "Unreal Script". I don't know whether it's possible but this answer cites the wrong source if it's correct. –  PeterT Feb 21 '12 at 10:58
    
The question is about whether you can open the project created in previous versions of UDK in the current Version or not, and the answer is yes as you need to make the code changes to make it compatible with the latest version of unreal script. –  Robin Feb 21 '12 at 11:31
    
The question is whether you can open older UDK3 projects in the never UDK3 Betas. It specifically says users can open Unreal Engine 3 packages not users can open Unreal Engine 2 or 3 packages –  PeterT Feb 21 '12 at 12:59
    
did you try to open one in udk3 by yourself or not? –  Robin Feb 22 '12 at 4:42
1  
I've never heard of UDK 2. There was no UDK for Unreal Engine 2, and I don't think there's ever been a version of UDK that didn't have Kismet. –  Phillip Feb 22 '12 at 4:47
show 2 more comments

True, the Unreal Development Kit only exists for Unreal Engine 3.

All of them support kismet.

You can load almost all content from an older version of UDK to a newer version with the exception of certain deprecated content such as the pre-Scaleform ui solution. Other things such as the old Terrain system were replaced with newer systems (Landscape) and thus need to be converted with in-engine utilities.

Also certain other things, like material editor nodes, may have become obsolete but are still in the engine, so you may need to go through and swap out old nodes (specifically certain depth nodes) for the newer ones.

Also Shader Model 2 support was deprecated so you could see some issues with left over fallback materials.

The bigger the leap forward the more work may need to be done to upgrade.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.