Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

For some reason I am getting nasty grey edges around the edges of rendered 3D models that are not present in Blender.

I seem to be able to solve the problem by reducing the size of the UV coordinates within the part of the texture that is to be mapped. But this means that:

  • I am wasting valuable texture space
  • Loss of accuracy in drawn UV maps

Could I be doing something wrong, perhaps a setting in Unity that needs changing? I have watched countless tutorials which demonstrate Blender default generated UV coordinates with "Texture Paint" which are perfectly aligned in Unity.

Here is an illustration of the problem:

  • Left: approximately 15 pixels of margin on each side of UV coordinates
  • Right: Approximately 3 pixels of margin on each side of UV coordinates

enter image description here

Note: Texture image resolution is 1024x1024

share|improve this question
    
Honestlly, it's more likely a Blender issue that it is a Unity issue. I've also noticed that when you unwrap your model in Blender, and then do "Export UV", if you then edit the exported PNG and re-apply it as texture in Blender, everything is shifted to the right about 2-3 pixels. Even if you simply apply the exported UVs image as texture you'll see that the UV coordinates don't perfectly align to the edges. –  Shivan Dragon Jan 22 '13 at 15:03
add comment

1 Answer

This apparently has to do with how MipMaps are generated, though, in personal experiments I could not reproduce your problem to quite the magnitude you have. My best guess is that you got a double-threat going on: Unity may not be importing the mesh at a high enough resolution, and the gradient color you have going on there may be calling more attention to it. Also consider that it may not be the texture at all, but a reflection effect for the material that you are using.

You may want to turn on interpolation in blender and go exploring with paint mode, to see if you don't have a UV error somewhere. Also, it seems like you have overlapping UV's, you should avoid that whenever possible, or at bare minimum make sure that they don't overlap perfectly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.