Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

Currently I've got a little 2.5D platformer with the camera tracking the player. Now when I go to insert a GUITexture or GUIText game object into the scene, it comes up absolutely fine in the Editor view, but when I go to play it there's absolutely nothing to be seen!

At first I thought it may have been a script I was using on the GUI, but I've tried it out with a completely bland GUITexture object that has no interaction with the rest of the game and I still get the same effect. I'm wondering if my camera is messing it up somehow, but I assumed that all GUI objects are drawn to screen space and just stay with the camera.

I've been really stuck for the past few hours so if any one could offer some insight, I'd be very, very grateful!

~Ray

share|improve this question

2 Answers 2

Make sure that you have selected a Game view like below:

share|improve this answer
up vote 4 down vote accepted

I can safely say that I am an idiot :)

Somehow, my camera got rid of the GUILayer component. Creating a new camera from scratch with all the prefabricated components fixed it.

I'll leave this here for posterity's sake, since this would be a pretty obscure thing to go wrong and there isn't any documentation I found on it.

But if a moderator feels differently, then they can close it :)

share|improve this answer
    
Just mark it as accepted so the community bot doesn't bump it. –  Tetrad Dec 7 '11 at 2:05
    
@Tetrad Thanks, I will do in 2 days. –  Ray Dey Dec 7 '11 at 2:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.