Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got the latest AndEngine code from Mercurial, added Android 1.6 to my Order/Export tab, and cleaned everything (including a "Fix" command as instructed by the console). Regardless of which version of Android I specify in my project settings (1.5, 1.6, 2.2, 3.2), I get around 523 compilation errors.

The most unique I can see is ETC1 cannot be resolved, accounting for 5 out of 105 errors I can see.

The other 100 are all some variation of The method [...] must override a superclass method.

What am I missing? I installed the JDK, Eclipse classic, SDK manager, and everything in the SDK.

share|improve this question
tried the forums? – Jari Komppa Sep 22 '11 at 5:26
Yeah, cross-posted to Gaming.SE and the forums. – ashes999 Sep 22 '11 at 10:30

You need to set the Compiler Compliance to 1.6, otherwise it will complain about almost every occurrence of an @Override annotation.

share|improve this answer

According to this thread on the andengine forums, the reason is:

Hey dude! That's because you're not using Android 2.2 in your project

share|improve this answer
I presume this means selecting "Android 2.2" in "Project Build Target." I tried this already, as I mentioned in my question, with various versions. – ashes999 Sep 22 '11 at 10:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.