Game Development Stack Exchange is a question and answer site for professional and independent game developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the CryENGINE SDK, and I tried the map Forest from within the editor and it worked fine. However, if I launch it from the Launcher using the console it looks like this:

I can use the weapons (although they are invisible) and interact with objects despite not seeing them. I also did my own map and had the same problem. What am I doing wrong?

share|improve this question
Is it possible that some resource files(such as textures or shaders) are missing in the directory in which you execute the launcher? or whatever path the map is (i know nothing about cryengine). It looks as if the diffuse layer is not being applied and it's only rendering light layers, but this is just a speculation, I couldn't really tell. – Pablo Ariel Sep 12 '11 at 6:10
Wouldn't it then not work in the editor as well? Because I'm not using the debug build I compiled myself but the build that came with the SDK – Predanoob Sep 12 '11 at 7:09
i don't know, but probably there is some field in the editor config telling "use this path as default for loading resources", and the launcher lacking of it. – Pablo Ariel Sep 12 '11 at 16:20

I think CryEngine probably compile shaders ( this in CryEninge can take a lot of time ) or engine have some problems with compiling shaders. Look in the log.

share|improve this answer
Yes definitly check logs, you will see the error right away. Unless it's a problem with video card/drivers? – DogDog Oct 19 '12 at 13:27
press ~ and check the errors in the console. Also make sure you have fxc.exe in the same dir, and rc.exe in rc folder – Andrew Douglas Oct 28 '13 at 5:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.