Take the 2-minute tour ×
Game Development Stack Exchange is a question and answer site for professional and independent game developers. It's 100% free, no registration required.

I just install Flash Player 11 and SDK 4.5 (hero), and test it with a small program. But I find it is still using "software" to simulate 3D API, and

trace("driver info: " + _context3D.driverInfo);

output

driver info: Software

I'm using windows 7, directX works properly, and option "-swf-version 13 -use-gpu" is already added in compiler arguments.

Who can tell me how to enable GPU in Flash Builder?

UPDATE:

context3d is constructed as :

private var _context3D:Context3D;
...
_context3D = stage3D.context3D;

And wmode is set to direct in html.

share|improve this question
    
how did you construct your _context3D ? –  dotminic Jun 13 '11 at 16:16
    
question is updated –  Huang F. Lei Jun 13 '11 at 17:18

2 Answers 2

Maybe your graphics-card isn't supported by the new Flash player? There's some more information about graphics-card compatibility over in this thread in the Adobe forums.

share|improve this answer
    
I had checked my card by d3dcaps yesterday. My card is Nvidia GTX465, it can run the zombie demo perfectly. –  Huang F. Lei Jun 14 '11 at 13:33

For some reason, you might have hardware acceleration disable. Right-click on an instance of the Flash Player in your browser and select settings. In the first tab, you should have hardware acceleration checked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.